Connection issues with starting new sessions
Incident Report for Discord
Resolved
This incident has been resolved.
Posted 8 days ago. Oct 10, 2018 - 17:29 PDT
Identified
The issue has been identified and we are working on fixing it.
Posted 8 days ago. Oct 10, 2018 - 17:07 PDT