Disconnects/Slow Message Sends
Incident Report for Discord
Resolved
Things look good and we believe the system has recovered fully.

We did take some actions to prevent this from recurring, notably expanding our gateway cluster, and we learned some things regarding Postgres' ability to be in the hot path of logins. We will be investigating these this coming week to continue to make improvements to the stability and resilience of Discord.

Thank you for your patience today, and good luck with the gaming!
Posted about 2 months ago. May 04, 2019 - 10:33 PDT
Monitoring
We have fully released the ravens and removed all of the limits. Discord should be functioning normally but we are keeping an eye on it.
Posted about 2 months ago. May 04, 2019 - 10:13 PDT
Identified
We identified an issue with our gateway cluster. It ran out of memory and crashed, resetting everybody's connection. We are having to rate limit logins to protect the underlying databases and bring Discord back up in a healthy fashion.

This means that logins will be slow for now while we continue to work to raise the threshold back to 100%, please bear with us.
Posted about 2 months ago. May 04, 2019 - 09:43 PDT
Investigating
We are aware of an issue disconnecting some users and making Discord slow to send messages. We are online and investigating.
Posted about 2 months ago. May 04, 2019 - 09:21 PDT