Looking into partial outage
Incident Report for Discord
Resolved
Everyone is looking fine again.
Posted over 3 years ago. Oct 24, 2015 - 04:48 PDT
Investigating
We are currently investigating this issue.
Posted over 3 years ago. Oct 24, 2015 - 04:36 PDT